Contact Us Contact Us

OpenSSL

  Software Depot
Electronic download
Frequently asked questions
PPS Software Depot
Product details & specifications
Installation

OpenSSL is a user-space component and it does not require a system reboot after installation.

You can install OpenSSL versions A.01.00.01m.001, A.00.09.08zf.001, A.00.09.08zf.002, and A.00.09.08zf.003 on top of an existing OpenSSL version.

However, if you have Internet Express OpenSSL version 0.9.7c installed on your system, you cannot upgrade to this release of OpenSSL.

You must remove the Internet Express OpenSSL 0.9.7c software before installing OpenSSL version A.01.00.01m.001, A.00.09.08zf.001, A.00.09.08zf.002, or A.00.09.08zf.003.

To verify if you have Internet Express installed, run the following command:

$ swlist | grep -i OPENSSL

If you see output with the "ix" prefix, you have Internet Express installed, and you need to uninstall it before installing this version of OpenSSL.

An example output is shown below:

ixOpenSSL A.02.00-0.9.7c Secure Network Communications Protocol

Prerequisites:

Following are the prerequisites for installing OpenSSL A.01.00.01m.001, A.00.09.08zf.001, A.00.09.08zf.002, and A.00.09.08zf.003:

  • HP-UX 11i v1, HP-UX 11i v2, or HP-UX 11i v3 operating systems
  • 600 MB free disk space

HP-UX 11i v1 users must install the following QPK bundle and the following libc patch before installing OpenSSL:

  • December 2002/SP-0203/5012-0049
    Note: OpenSSL has been tested with this QPK bundle. You can also choose to use the latest QPK bundle as these bundles are cumulative in nature.
  • PHCO_28427

Installation procedure:

To install OpenSSL A.01.00.01m.001, A.00.09.08zf.001, A.00.09.08zf.002, and A.00.09.08zf.003 on HP-UX 11i v1, HP-UX 11i v2, or HP-UX 11i v3 operating systems:

  1. Log on to the system as root.
  2. Download the OpenSSL software depot from http://www.software.hp.com/ to the /tmp directory on your system.
    The following Table 1 lists the OpenSSL depots available for HP-UX 11i v1, HP-UX 11i v2, and HP-UX 11i v3 operating systems.

Table 1: OpenSSL depots for HP-UX 11i v1, HP-UX 11i v2, and HP-UX 11i v3 Operating Systems

Operating System

Depot Name

HP-UX 11i v1

OpenSSL_A.00.09.08zf.001_HP-UX_B.11.11_32_64.depot

HP-UX 11i v2

OpenSSL_A.00.09.08zf.002_HP-UX_B.11.23_IA-PA.depot

HP-UX 11i v3

OpenSSL_A.00.09.08zf.003_HP-UX_B.11.31_IA-PA.depot

HP-UX 11i v3

OpenSSL_A.01.00.01m.001_HP-UX_B.11.31_IA-PA.depot

(The PA bits are from A.00.09.08zf)

  1. Run the following swlist command to verify that you have downloaded the OpenSSL depot correctly:

    # swlist -d -s /tmp/OpenSSL*.depot
 
For 11i v1:OpenSSL  A.00.09.08zf.001 	Secure Network Communications Protocol
For 11i v2:OpenSSL  A.00.09.08zf.002 	Secure Network Communications Protocol
For 11i v3:OpenSSL  A.00.09.08zf.003 	Secure Network Communications Protocol
For 11i v3:OpenSSL  A.01.00.01m.001 	Secure Network Communications Protocol (PA: 0.9.8zf,IA: 1.0.1m)

4.  To install OpenSSL, fips_2_0_5, fips_1_2, and fips_1_1_2 products, run the following command:

# swinstall -s /tmp/OpenSSL*.depot OpenSSL

To install the OpenSSL product only, run the following command:

# swinstall -s /tmp/OpenSSL*.depot openssl

To install the FIPS Capable OpenSSL product (FIPS 2.0.5 object module and 1.0.1m-based FIPS Compatible OpenSSL on 11i v3 integrity system) only, enter the following command:

# swinstall -s /tmp/OpenSSL*.depot fips_2_0_5

To install the FIPS Capable OpenSSL product (FIPS 1.2 object module and 0.9.8zf-based FIPS Compatible OpenSSL) only, enter the following command:

# swinstall -s /tmp/OpenSSL*.depot fips_1_2

The swinstall command installs the OpenSSL software in the /opt/openssl directory.

To install the FIPS Capable OpenSSL product (FIPS 1.1.2 object module and 0.9.7m-based FIPS Compatible OpenSSL) only, enter the following command:

# swinstall -s /tmp/OpenSSL*.depot fips_1_1_2

Installation Overview
Select